Code

Opened 4 years ago

Closed 4 years ago

Last modified 3 years ago

#13191 closed (duplicate)

Localization of application names

Reported by: IsakovAN Owned by: nobody
Component: Internationalization Version: 1.1
Severity: Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

I have a solution for localizing application names in admin interface. First of all I have replace "{{ app_label|capfirst }}" with "{% trans app_label.title %}" in all admin templates breadcrumbs and aplication lists:
app_index.html
base.html
base_site.html
change_form.html
change_list.html
delete_confirmation.html
delete_selected_confirmation.html
index.html
object_history.html

Than I have simple translate it with makemessages/compilemessages. It is only problem with "/admin/app_name/" pages:
"'title': _('%s administration') % capfirst(app_label)," hardcoded in /django/contrib/admin/sites.py seems bad idea. I suggest to replace it with
"'title': _('%s administration') % _(capfirst(app_label)),"

I can make a full patch if you interesting.

Attachments (0)

Change History (2)

comment:1 Changed 4 years ago by ubernostrum

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

Multiple problems:

  1. Several tickets are already open for this issue, so opening yet another one is the wrong approach. See #1668 or #10436 for a starting point.
  2. Since this doesn't cover a regression of functionality or loss of data, there's no way it should be on the 1.2 milestone.

comment:2 Changed 3 years ago by jacob

  • milestone 1.2 deleted

Milestone 1.2 deleted

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.