Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#13153 closed (fixed)

An rpm fails to build with python setup.py bdist_rpm

Reported by: cesar@… Owned by: nobody
Component: Uncategorized Version: master
Severity: Keywords:
Cc: Triage Stage: Ready for checkin
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

Two issues prevent an rpm package to be built with a python setup.py bdist_rpm command. At least this applies to CentOS 5.4, but I don't think it is distro-dependent.

The first one is version number. Here's a crash log:

creating dist
tar -cf dist/Django-1.2-beta-1.tar Django-1.2-beta-1
gzip -f9 dist/Django-1.2-beta-1.tar
removing 'Django-1.2-beta-1' (and everything under it)
copying dist/Django-1.2-beta-1.tar.gz -> build/bdist.linux-x86_64/rpm/SOURCES
building RPMs
rpmbuild -ba --define _topdir /home/cesar/package/django/build/bdist.linux-x86_64/rpm --clean build/bdist.linux-x86_64/rpm/SPECS/Django.spec
error: File /home/cesar/package/django/build/bdist.linux-x86_64/rpm/SOURCES/Django-1.2_beta_1.tar.gz: No such file or directory
error: command 'rpmbuild' failed with exit status 1

For svn-based builds version is formatted as Django-1.2-beta-1. This version scheme violates RPM rules (see RPM File Naming Convention) as it introduces an extra dash.

Patch version.diff changes version formatting for SVN versions (e.g. Django-1.2_beta_1_svn~12743-1).

The second issue is with source:django/trunk/setup.cfg file. It lists examples directory as containing doc files, while it is missing in the repo. Attached doc_files.diff simply removes it.

Upon applying both of these patches I managed to build and install bleeding edge Django version with yum package manager.

Attachments (2)

version.diff (729 bytes) - added by cesar@… 5 years ago.
doc_files.diff (338 bytes) - added by cesar@… 5 years ago.

Download all attachments as: .zip

Change History (8)

Changed 5 years ago by cesar@…

Changed 5 years ago by cesar@…

comment:1 Changed 5 years ago by russellm

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset

Duplicate of #9616.

comment:2 Changed 5 years ago by russellm

  • Resolution set to duplicate
  • Status changed from new to closed

comment:3 Changed 5 years ago by grugnog@…

  • Resolution duplicate deleted
  • Status changed from closed to reopened

The first issue is indeed a duplicate of #9616, but the second issue does not appear to be duplicate at all. The doc_files.diff patch still applies - should a new ticket be created, or can we proceed here?

comment:4 Changed 5 years ago by russellm

  • Triage Stage changed from Unreviewed to Ready for checkin

We can keep this ticket open.

As a side note - this is why we say "one issue per ticket" :-)

comment:5 Changed 5 years ago by russellm

  • Resolution set to fixed
  • Status changed from reopened to closed

(In [13487]) Fixed #13153 -- Removed a stale reference to the examples directory in setup.cfg. Thanks to cesar@… for the report.

comment:6 Changed 5 years ago by russellm

(In [13488]) [1.2.X] Fixed #13153 -- Removed a stale reference to the examples directory in setup.cfg. Thanks to cesar@… for the report.

Backport of r13487 from trunk.

Note: See TracTickets for help on using tickets.
Back to Top