Opened 5 years ago

Closed 5 years ago

Last modified 3 years ago

#13130 closed (duplicate)

Delete selected in admin seems broken

Reported by: edin1 Owned by: nobody
Component: contrib.admin Version: master
Severity: Keywords: bulk delete selection selected
Cc: Triage Stage: Accepted
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

I'm relatively new to Django, but not to Python in general nor to the web frameworks.

The bulk delete action from the admin pages appears to be broken in the current SVN.

After a bit of investigating I think that the problem is in django.contrib.admin.actions, function delete_selected, (line 20 of actions.py).

The problematic line is line 43:

    if request.POST.get('post'):

where request.POST.get('post') returns None or something similar.

Change History (3)

comment:1 Changed 5 years ago by russellm

  • milestone set to 1.2
  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Triage Stage changed from Unreviewed to Accepted

This is a fairly major regression; not sure how it slipped in.

comment:2 Changed 5 years ago by kmtracey

  • Resolution set to duplicate
  • Status changed from new to closed

We've already got a ticket for this: #12962

comment:3 Changed 3 years ago by jacob

  • milestone 1.2 deleted

Milestone 1.2 deleted

Note: See TracTickets for help on using tickets.
Back to Top