Code

Opened 4 years ago

Closed 4 years ago

#13109 closed (duplicate)

template tag ssi, doesn't resolve variable name for path

Reported by: htumblin Owned by: nobody
Component: Template system Version: 1.1
Severity: Keywords: templatetag ssi
Cc: Triage Stage: Unreviewed
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

When attempting to use the {% ssi foo %} template tag, the documentation indicates that its similar to the {% include foo %} tag. The include tag allows one to specify the file to include as a variable or as a string. ssi does not support having a variable here.

Additionally, if in debug mode, ssi displays a message if it doesn't have permission to the file, I added the filename to this message. Helps with debugging.

I've attached my diff file. I did an svn update before I made my changes, so this diff should be pretty current against the trunk.

Thanks

/Henry

Attachments (1)

defaulttags.py-patch (794 bytes) - added by htumblin 4 years ago.
svn diff output

Download all attachments as: .zip

Change History (2)

Changed 4 years ago by htumblin

svn diff output

comment:1 Changed 4 years ago by russellm

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #9666

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.