Code

Opened 4 years ago

Closed 3 years ago

#13106 closed Bug (duplicate)

Show confirmation page when deleting objects from an inline form

Reported by: bmjames Owned by: nobody
Component: contrib.admin Version: 1.1
Severity: Normal Keywords:
Cc: Triage Stage: Accepted
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: yes

Description

Currently (1.1.1) if objects are deleted using the form of an InlineModelAdmin, no confirmation page is shown regarding deleting objects related to the deleted item. The item that was in the inline form, and all its related objects, are silently deleted.

Attachments (0)

Change History (6)

comment:1 Changed 4 years ago by russellm

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Triage Stage changed from Unreviewed to Accepted

comment:2 Changed 3 years ago by lukeplant

  • Type set to Bug

comment:3 Changed 3 years ago by lukeplant

  • Severity set to Normal

comment:4 Changed 3 years ago by julien

  • Easy pickings unset
  • UI/UX unset

Related issue: #14411.

comment:5 Changed 3 years ago by julien

  • UI/UX set

comment:6 Changed 3 years ago by ramiro

  • Resolution set to duplicate
  • Status changed from new to closed

I'm going to close this as a duplicate of #14411 that, although is newer, has sparked some discussion.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.