Opened 6 years ago

Closed 6 years ago

Last modified 4 years ago

#12703 closed (fixed)

admin_view test failures caused by r12297

Reported by: russellm Owned by: nobody
Component: contrib.admin Version: master
Severity: Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

Updating to a trunk after r12297 yields two test suite failures:

======================================================================
FAIL: test_changelist_input_html (regressiontests.admin_views.tests.AdminViewListEditable)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/Users/rkm/projects/django/hg/tests/regressiontests/admin_views/tests.py", line 936, in test_changelist_input_html
    self.failUnlessEqual(response.content.count("<input"), 16)
AssertionError: 17 != 16

======================================================================
FAIL: test_readonly_get (regressiontests.admin_views.tests.ReadonlyTest)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/Users/rkm/projects/django/hg/tests/regressiontests/admin_views/tests.py", line 1758, in test_readonly_get
    self.assertEqual(response.content.count("input"), 10)
AssertionError: 5 != 10

----------------------------------------------------------------------
Ran 2 tests in 0.843s

Change History (4)

comment:1 Changed 6 years ago by russellm

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to fixed
  • Status changed from new to closed

(In [12308]) Fixed #12703 -- Corrected a test suite failure in the admin_views tests.

comment:2 Changed 6 years ago by russellm

For the record, this actually only fixes the first of the two failures. It looks like the second failure is a real failure caused by an incorrect implementation. I've opened r12704 to track this separate issue.

comment:3 Changed 6 years ago by jezdez

(In [12369]) Fixed #12692 - Properly handle the extra clause of admin inline formsets. Also fixes #12703, second error.

comment:4 Changed 4 years ago by jacob

  • milestone 1.2 deleted

Milestone 1.2 deleted

Note: See TracTickets for help on using tickets.
Back to Top