Code

Opened 4 years ago

Closed 4 years ago

#12442 closed (wontfix)

PasswordResetForm ignores TEMPLATE_CONTEXT_PROCESSORS

Reported by: Art_S Owned by: nobody
Component: Contrib apps Version: 1.1
Severity: Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

When rendering template, PasswordResetForm supplies only local context, ignoring whatever is in TEMPLATE_CONTEXT_PROCESSORS

Attachments (0)

Change History (1)

comment:1 Changed 4 years ago by lukeplant

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to wontfix
  • Status changed from new to closed

I presume you are talking about the e-mail template, in which case yes, this is true, because PasswordResetForm uses Context and not RequestContext. It cannot use the latter because it does not have access to the request object. (For a request to change that, see #12372)

Closing WONTFIX because this is intended behaviour.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.