Code

Opened 5 years ago

Closed 5 years ago

#12232 closed (duplicate)

Dead links in recent actions and invalid entries in object history

Reported by: anonymous Owned by: nobody
Component: Uncategorized Version: 1.1
Severity: Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

If we delete an object the add and change links on recent actions are dead. Also if two objects have the same ID (create a new object after a deletion) they have the same object history.

Attachments (2)

t12232_r11366.patch (4.5 KB) - added by anonymous 5 years ago.
t12232_r11366.evolution.py (214 bytes) - added by anonymous 5 years ago.
django-evolution script to add db field for migrations

Download all attachments as: .zip

Change History (3)

comment:1 Changed 5 years ago by kmtracey

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

Note the proposed patch changes the LogEntry model -- any such change would require some migration plan, since existing installations do not have this new field in LogEntry and install of a new version of Django wouldn't automatically update existing tables. Thus running the new level of code against a database created with an older level would promptly break.

This is also a duplicate of #1611, which was closed wontfix. (Adrian's first alternative for fixing it is essentially what is proposed here, except he proposed to delete the existing log entries instead of updating them with a flag.) The part that is not a dupe (reusing primary keys of deleted objects) is even more of an edge case.

Changed 5 years ago by anonymous

Changed 5 years ago by anonymous

django-evolution script to add db field for migrations

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.