Opened 6 years ago

Closed 6 years ago

#12179 closed (duplicate)

Should be able to manually store non-text in the memcached backend

Reported by: joshuajonah Owned by: nobody
Component: Core (Cache system) Version: master
Severity: Keywords: gzip
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:


I am using a function that stores gzipped content in the memcached backend. The built in memcached cache.get() runs smart_unicode() on the returned text if it is detected as a string. Gzipped content is qualified as str or uncode via "if isinstance(val, basestring):", however there needs to be a way to avoid this in my case.

I've attached a simple diff in the form of an optional kwarg that works for me.

Attachments (1)

raw.diff (703 bytes) - added by joshuajonah 6 years ago.

Download all attachments as: .zip

Change History (2)

comment:1 Changed 6 years ago by Alex

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

Dupe of #12178.

Changed 6 years ago by joshuajonah

Note: See TracTickets for help on using tickets.
Back to Top