Opened 7 years ago

Closed 7 years ago

#12178 closed (duplicate)

Should be able to manually store non-text in the memcached backend

Reported by: joshuajonah Owned by: nobody
Component: Core (Cache system) Version: master
Severity: Keywords: gzip
Cc: josh@… Triage Stage: Unreviewed
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

I am using a function that stores gzipped content in the memcached backend. The built in memcached cache.get() runs smart_unicode() on the returned text if it is detected as a string. Gzipped content is qualified as str or uncode via "if isinstance(val, basestring):", however there needs to be a way to avoid this in my case.

I've attached a simple diff in the form of an optional kwarg that works for me.

Attachments (1)

raw.diff (703 bytes) - added by joshuajonah 7 years ago.

Download all attachments as: .zip

Change History (6)

Changed 7 years ago by joshuajonah

Attachment: raw.diff added

comment:1 Changed 7 years ago by joshuajonah

Has patch: set
Needs documentation: unset
Needs tests: unset
Patch needs improvement: unset

comment:2 Changed 7 years ago by Ramiro Morales

Isn't this one a duplicate of #11012?

comment:3 Changed 7 years ago by joshuajonah

Nice find.

Technically yes, but I like the manual override option better. Plus it's a lot simpler.

comment:4 Changed 7 years ago by joshuajonah

Cc: josh@… added

comment:5 Changed 7 years ago by Russell Keith-Magee

Resolution: duplicate
Status: newclosed

Dupe of #11012.

Note: See TracTickets for help on using tickets.
Back to Top