Code

Opened 4 years ago

Closed 4 years ago

#12081 closed (invalid)

My project is not detecting the geodjango application

Reported by: sahitip Owned by: nobody
Component: GIS Version: 1.1
Severity: Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description (last modified by Alex)

Hello .. I want to have google maps in my application, so i created a project and in that made an application to handle the maps and made the required changes in the settings.py for the above. But i am getting the following error when i am trying to issue the command "python manage.py sqlall world"

Error: App with label world could not be found. Are you sure your INSTALLED_APPS setting is correct?

Can some one please help in this issue . And my models file is as follows:

from django.contrib.gis.db import models

class WorldBorders(models.Model):
    # Regular Django fields corresponding to the attributes in the
    # world borders shapefile.
    name = models.CharField(max_length=50)
    area = models.IntegerField()
    pop2005 = models.IntegerField('Population 2005')
    fips = models.CharField('FIPS Code', max_length=2)
    iso2 = models.CharField('2 Digit ISO', max_length=2)
    iso3 = models.CharField('3 Digit ISO', max_length=3)
    un = models.IntegerField('United Nations Code')
    region = models.IntegerField('Region Code')
    subregion = models.IntegerField('Sub-Region Code')
    lon = models.FloatField()
    lat = models.FloatField()

 #    GeoDjango-specific: a geometry field (MultiPolygonField), and
 #    overriding the default manager with a GeoManager instance.
    mpoly = models.MultiPolygonField()
    objects = models.GeoManager()

    # So the model is pluralized correctly in the admin.
    class Meta:
        verbose_name_plural = "World Borders"

    # Returns the string representation of the model.
    def __unicode__(self):
        return self.name

Attachments (0)

Change History (4)

comment:1 Changed 4 years ago by Alex

  • Description modified (diff)
  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset

Please use the preview button.

comment:2 Changed 4 years ago by jbronn

  • Resolution set to worksforme
  • Status changed from new to closed

Did you follow the installation directions? Did you put 'world' in your INSTALLED_APPS? I cannot reproduce and there's no indication here of a bug, but rather improper configuration and/or installation.

Please use the mailing list or IRC for help requests; this is not a bug.

comment:3 follow-up: Changed 4 years ago by intsangity

  • Resolution worksforme deleted
  • Status changed from closed to reopened

This is broken in release 1.1.1 again. It works fine in release 1.0.4.

comment:4 in reply to: ↑ 3 Changed 4 years ago by jbronn

  • Resolution set to invalid
  • Status changed from reopened to closed

Replying to intsangity:

This is broken in release 1.1.1 again. It works fine in release 1.0.4.

Do not reopen tickets that have been closed by a core developer absent a compelling reason. Simply asserting that it's "broken in release 1.1.1 again" is not compelling. Something is wrong with your configuration, as I've independently verified the tutorial code does work with the 1.1.1 release.

Before you reopen, please provide detailed steps that clearly demonstrates this problem -- I'm still sure you are missing 'world' and/or 'django.contrib.gis' from your INSTALLED_APPS.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.