Code

Opened 5 years ago

Closed 4 years ago

#12041 closed (duplicate)

Wrap messages in block in admin base template

Reported by: bendavis78 Owned by: bendavis78
Component: contrib.admin Version: master
Severity: Keywords: messages template
Cc: Triage Stage: Unreviewed
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

Sometimes it is useful to be able to override how messages are displayed in the admin site. For example, if you want to have different message types (e.g., error, warning, etc..) you'll need to be able to override the messages <ul> in base.html. Unfortunately, it's not in a block so you'd have to copy the entire base.html to your app, which is not good.

This simple patch wraps it in block tags so it can be overridden.

Attachments (1)

messages_block.diff (772 bytes) - added by bendavis78 5 years ago.
Patch to allow messages <ul> in base.html to be overridden

Download all attachments as: .zip

Change History (4)

Changed 5 years ago by bendavis78

Patch to allow messages <ul> in base.html to be overridden

comment:1 Changed 5 years ago by bendavis78

  • Has patch set
  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset

comment:2 Changed 5 years ago by bendavis78

  • Owner changed from nobody to bendavis78
  • Status changed from new to assigned

comment:3 Changed 4 years ago by russellm

  • Resolution set to duplicate
  • Status changed from assigned to closed

Duplicate of #10917

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.