Opened 5 years ago

Closed 3 years ago

#11817 closed Bug (worksforme)

Incorrect document structures in django-documentation

Reported by: axel Owned by: nobody
Component: contrib.admindocs Version: 1.1
Severity: Normal Keywords:
Cc: josh@… Triage Stage: Accepted
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

Some templates of the django documentation respectively the contents contain incorrect document structures - e.g.


Template tag documentation

<h4><p>Force autoescape behaviour for this block.</p></h4>
<p/>

The h4 should not contain a p

The single p after the h4 should be removed

Change History (8)

comment:1 Changed 5 years ago by joshuajonah

  • Cc josh@… added
  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset

If you have time, can you link the the problem pages?

comment:2 Changed 5 years ago by Kellen

That line is from http://code.djangoproject.com/browser/django/trunk/django/template/defaulttags.py#L436 but I don't see the text anywhere in the normal documentation.

comment:3 Changed 5 years ago by timo

  • Component changed from Documentation to Contrib apps

This is actually from "Template tag documentation" page (/admin/doc/tags/) generated by the django.contrib.admindocs.

comment:4 Changed 5 years ago by russellm

  • Triage Stage changed from Unreviewed to Accepted

comment:5 Changed 4 years ago by bpeschier

With all the cleaning going on and new versions of docutils, this seems to have gone away? I cannot reproduce it anymore.

comment:6 Changed 4 years ago by gabrielhurley

  • Component changed from Contrib apps to Documentation

comment:7 Changed 4 years ago by julien

  • Component changed from Documentation to contrib.admindocs
  • Easy pickings unset
  • Severity set to Normal
  • Type set to Bug

comment:8 Changed 3 years ago by aaugustin

  • Resolution set to worksforme
  • Status changed from new to closed
  • UI/UX unset

I confirm this bug no longer exists.

Here's the current output corresponding to the bug report:

<h1>Template tag documentation</h1>

<div id="content-main">


<div class="module">
    <h2>Built-in tags</h2>
    
    
    <h3 id="built_in-autoescape">autoescape</h3>
    <h4>Force autoescape behavior for this block.
</h4>
    
    <hr />
    
    <h3 id="built_in-block">block</h3>
    <h4>Define a block that can be overridden by child templates.
</h4>
    
    <hr />
    
    <h3 id="built_in-comment">comment</h3>
    <h4>Ignores everything between {% comment %} and {% endcomment %}.
</h4>
    
    <hr />

...
Note: See TracTickets for help on using tickets.
Back to Top