Code

Opened 5 years ago

Closed 4 years ago

Last modified 4 years ago

#11800 closed (fixed)

Remove extra metadata from QuerySet API

Reported by: timo Owned by: timo
Component: Documentation Version: master
Severity: Keywords:
Cc: Triage Stage: Ready for checkin
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description (last modified by russellm)

Attached is a patch that adds content-sensitive Sphinx markup to the API documentation, replacing old-style ReST markup.

Attachments (1)

11800.diff (7.1 KB) - added by timo 4 years ago.

Download all attachments as: .zip

Change History (9)

comment:1 Changed 5 years ago by russellm

  • Description modified (diff)
  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Triage Stage changed from Unreviewed to Ready for checkin

@timo - thanks for the patch, but seriously - a ticket description isn't an optional extra. "Add metadata to QuerySet API"? WTF does that mean?

comment:2 follow-up: Changed 5 years ago by Alex

I believe Jacob has been working on/did a patch for Sphinx that allowed any literals to automatically become cross references, so this may be unnecessary.

comment:3 Changed 4 years ago by russellm

  • Patch needs improvement set
  • Triage Stage changed from Ready for checkin to Accepted

Patch no longer applies cleanly.

comment:4 in reply to: ↑ 2 Changed 4 years ago by ramiro

Replying to Alex:

I believe Jacob has been working on/did a patch for Sphinx that allowed any literals to automatically become cross references, so this may be unnecessary.

I did something similar as what timo did in this ticket for the ':setting:', ':mod:', ':class:', :data: and ':attr:' xref targets over all the documetation during the 1.1.x cycle in #9502, updating it during almost four months so it always applied cleanly both for trunk and the 1.0.x branch. In the end I abandoned it because after asking why it wasn't applied on IRC I was told a solution was coming RSN and would render that patch obsolete.

We need to decide and make public what we are going to do with this stuff so to to not waste contributors energy spent in adding metadata to the docs and end with patches that get outdated (it's one of our docs TODO list).

comment:5 Changed 4 years ago by timo

  • Owner changed from nobody to timo
  • Status changed from new to assigned

This is mostly a duplicate of #12997 at this point, although as I pointed out in that ticket, the current metadata is a bit broken. There a few things to cleanup so I'll redo this patch at some point.

ramiro, did you get any clarification on the issue of linking? (I noticed you "won't fixed" #9502). If it's no longer needed or wanted, we should remove it from the TODO list as you noted.

Changed 4 years ago by timo

comment:6 Changed 4 years ago by timo

  • Patch needs improvement unset
  • Summary changed from Add metadata to QuerySet API to Remove extra metadata from QuerySet API
  • Triage Stage changed from Accepted to Ready for checkin

modifying patch to remove extra metadata after additions in #12997

comment:7 Changed 4 years ago by russellm

  • Resolution set to fixed
  • Status changed from assigned to closed

(In [13548]) Fixed #11800 -- Updated Sphinx metadata in queryset docs. Thanks to timo for the patch.

comment:8 Changed 4 years ago by russellm

(In [13549]) [1.2.X] Fixed #11800 -- Updated Sphinx metadata in queryset docs. Thanks to timo for the patch.

Backport of r13548 from trunk.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.