Code

Opened 5 years ago

Closed 5 years ago

#11636 closed (duplicate)

New intdot function for django.contrib.humanize

Reported by: bymenda Owned by: nobody
Component: Contrib apps Version: 1.0
Severity: Keywords: spain, long numbers, dot
Cc: Triage Stage: Unreviewed
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

Hi all.

I would like to contribute with a little function for the package django.contrib.humanize.

In Spain we don't use commas for long numbers like 45,000. Instead of that we use dots, so the example before would be 45.000. I ignore if other countries from Europe or the World have that rule, but here it's like that.

I'm currently using "Django version 1.0.2 final" on Debian 5.0 (Lenny), and this patch is for this version. I ignore if new changes have been done to the module, but I'm sure you can easily adapt to it.

Thanks for reading this,
Rafa Muñoz Cárdenas.

Attachments (1)

humanize.patch (690 bytes) - added by bymenda 5 years ago.

Download all attachments as: .zip

Change History (2)

Changed 5 years ago by bymenda

comment:1 Changed 5 years ago by dc

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #3940 and is fixed in branches/soc2009/i18n-improvements.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.