Opened 6 years ago

Closed 6 years ago

#11620 closed (worksforme)

Tutorial part II, page 1, gives error message when followed.

Reported by: thegreygeek Owned by: nobody
Component: Documentation Version: 1.1-beta
Severity: Keywords: tutorial part II, admin
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:


Admin screen will not run when tutorial is followed.

I hacked around and found that making a change in will correct the error.

I uncommented the line


and that found the correct template and admin ran.

EGGS? must be inside joke.

Change History (1)

comment:1 Changed 6 years ago by kmtracey

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to worksforme
  • Status changed from new to closed

Eggs are a Python thing. For a normal Django install, you don't need to uncomment that line to get admin working. The fact that uncommenting it for you makes admin work would seem to imply you are running Django out of an egg file, which seems odd if you don't even know what eggs are. You might want to post on IRC or django-users including information about how you installed Django to get an explanation for why you need that template loader enabled. I don't see that there's a bug in the tutorial here, though, as plenty of people have followed it after using the linked install instructions, and not needed to uncomment that line to get admin working.

Note: See TracTickets for help on using tickets.
Back to Top