Code

Opened 5 years ago

Closed 5 years ago

Last modified 3 years ago

#11411 closed (duplicate)

DecimalField and NaN

Reported by: kovalidis@… Owned by: nobody
Component: Forms Version: 1.0
Severity: Keywords: DecimalField,NaN
Cc: Triage Stage: Unreviewed
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

When save form with DecimalField which has NaN value I get exception:

Exception Type:  	TypeError
Exception Value: 	bad operand type for abs(): 'str'
Exception Location: 	/var/lib/python-support/python2.6/django/forms/fields.py in clean, line 254

Because clean method of DecimalField doesn't check that value can be 'NaN'.

I use django 1.0.2.

Attachments (1)

fields.diff (428 bytes) - added by kovalidis@… 5 years ago.

Download all attachments as: .zip

Change History (3)

Changed 5 years ago by kovalidis@…

comment:1 Changed 5 years ago by ramiro

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

duplicate of #7777

comment:2 Changed 3 years ago by jacob

  • milestone 1.0.3 deleted

Milestone 1.0.3 deleted

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.