Opened 6 years ago

Closed 6 years ago

#11351 closed (worksforme)

IE6 times out in the Django Development Server when a Request.Post is passed

Reported by: philip.barkow@… Owned by: nobody
Component: HTTP handling Version: 1.0
Severity: Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

Using the Django Development Server.
Internet Explorer 6.0 Service Pack 2.
Windows XP 2.

Intermittent "Cannot find server" error when a request.post is passed to a view and the view then attempts to return an HTTPResponse.
This error occurs more often than not.

Switching to Firefox fixes this problem.

Change History (3)

comment:1 Changed 6 years ago by ubernostrum

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to invalid
  • Status changed from new to closed

This doesn't seem to report a Django bug; please consider asking in a help forum like the django-users mailing list.

comment:2 Changed 6 years ago by anonymous

  • Resolution invalid deleted
  • Status changed from closed to reopened

Similar problem. Server not found error.

Manifests itself using IE 6 and 7 using the dev. server (manage.py runserver).
Does not manifest using apache22/mod_python. Reproduced on another workstation.
Custom views and the Django administrator as well.

Process seems to be POST-> do some processing-> HTTPResponseRedirect->
failure.

Python 2.6, Django 1.1.

comment:3 Changed 6 years ago by russellm

  • Resolution set to worksforme
  • Status changed from reopened to closed

Trac isn't for handling "customer support" issues - it's for tracking clearly identifiable bugs in Django. This report doesn't identify a bug - it reports a problem that is specific to your install. I strongly suspect that it is a local configuration or code issue, since I use the Django development server all day and haven't seen this problem.

Without a clear reproducible test case, there isn't much else we can do to help here. If you can isolate a specific Django-specific cause, feel free to reopen this ticket. In the meantime, django-users is where you should be asking questions like this.

In the absence of specific details, I'm going to mark this worksforme (since it does).

Note: See TracTickets for help on using tickets.
Back to Top