Opened 6 years ago

Closed 6 years ago

#11275 closed (duplicate)

Missing Parameter in String Substitution in Admin-Logout-View-Name

Reported by: joh@… Owned by: nobody
Component: contrib.admin Version: master
Severity: Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

Just discovered that the view-name of the logout-view is missing a parameter for string substitution, see http://code.djangoproject.com/browser/django/trunk/django/contrib/admin/sites.py#L202

When I print the resulting patterns of AdminSite.get_urls it contains <RegexURLPattern %sadmin_logout ^logout/$> but I think it should look like <RegexURLPattern admin_logout ^logout/$> or if the site contains a name like <RegexURLPattern myprefix_admin_logout ^logout/$>.

Change History (1)

comment:1 Changed 6 years ago by kmtracey

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

#11080 was a report of the same thing, closed as a dupe of #10061.

Note: See TracTickets for help on using tickets.
Back to Top