Code

Opened 5 years ago

Closed 5 years ago

#11080 closed (duplicate)

Named URL pattern for admin logout is missing

Reported by: basti Owned by: nobody
Component: contrib.admin Version: master
Severity: Keywords:
Cc: Triage Stage: Unreviewed
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

I stumbled over this section by accident.

url(r'^$',
  wrap(self.index),
 name='%sadmin_index' % self.name),
url(r'^logout/$',
  wrap(self.logout),
  name='%sadmin_logout'),

Seems that the string substitution for the named URL pattern of the logout link is missing.

Attachments (1)

sites.patch (585 bytes) - added by basti 5 years ago.

Download all attachments as: .zip

Change History (3)

Changed 5 years ago by basti

comment:1 Changed 5 years ago by basti

  • Component changed from Uncategorized to django.contrib.admin
  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset

comment:2 Changed 5 years ago by Alex

  • Resolution set to duplicate
  • Status changed from new to closed

Marking as a dupe of #10061 since this is solved here, and this fix alone doesn't fix the myriad of problems with logout.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.