Code

Opened 5 years ago

Closed 5 years ago

#10818 closed (invalid)

auth tests fail for projects which override registration templates

Reported by: SmileyChris Owned by: SmileyChris
Component: contrib.auth Version: master
Severity: Keywords:
Cc: Triage Stage: Ready for checkin
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

The problem is due to the now loudly failing {% url %} tag. If you override a registration template with one which uses a URL tag, you'll end up with your project tests failing loudly for the contrib.auth tests.

The solution is to put default templates in the test directory (and make sure all the tests use them)

Attachments (1)

10818.diff (4.0 KB) - added by SmileyChris 5 years ago.

Download all attachments as: .zip

Change History (4)

Changed 5 years ago by SmileyChris

comment:1 Changed 5 years ago by SmileyChris

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Summary changed from auth tests fail due to overridden templates to auth tests fail for projects which override registration templates
  • Triage Stage changed from Unreviewed to Ready for checkin

(preview doesn't show that the new files actually contain {{ form.as_ul }})

This issue has bugged me on multiple projects, and this simple fix makes it work across the board.
I'll just be brash and push this direct to ready for checkin. Feel free to slap me round if it's not, committers :P

comment:2 Changed 5 years ago by SmileyChris

  • Owner changed from nobody to SmileyChris
  • Status changed from new to assigned

comment:3 Changed 5 years ago by SmileyChris

  • Resolution set to invalid
  • Status changed from assigned to closed

Yawn... I should really svn up before I start working on things, fixed as a side effect by #10747

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.