Opened 7 years ago

Closed 7 years ago

#10775 closed (duplicate)

utils/ should not assume that it has access to the file system

Reported by: mad Owned by: mad
Component: Uncategorized Version: 1.0
Severity: Keywords:
Cc: Triage Stage: Unreviewed
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:


When running a DJango app on a server without file access (like Google's AppEngine), the utils/ get_svn_revision method throws an exception and the app fails initializing.

Attachments (1)

fix.txt (2.1 KB) - added by mad 7 years ago.
small fix by catching exceptions and simply continuing

Download all attachments as: .zip

Change History (2)

Changed 7 years ago by mad

small fix by catching exceptions and simply continuing

comment:1 Changed 7 years ago by ubernostrum

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #10372, which has already been fixed in both trunk and in the 1.0.X release branch.

In the future, please search the ticket tracker before filing a new ticket.

Note: See TracTickets for help on using tickets.
Back to Top