Opened 7 years ago

Closed 6 years ago

Last modified 4 years ago

#10588 closed (duplicate)

pass status parameter through render_to_response

Reported by: novas0x2a Owned by: ccahoon
Component: HTTP handling Version: master
Severity: Keywords:
Cc: Triage Stage: Someday/Maybe
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:


This makes it so render_to_response can be used to render custom error pages (by setting status=404, etc).

Attachments (1)

0001-pass-render_to_response-status-param-through-to-Http.patch (3.5 KB) - added by novas0x2a 7 years ago.

Download all attachments as: .zip

Change History (7)

comment:1 Changed 7 years ago by thatch

  • Component changed from Uncategorized to HTTP handling
  • milestone set to 1.2
  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Triage Stage changed from Unreviewed to Design decision needed

comment:2 Changed 6 years ago by ccahoon

  • Owner changed from nobody to ccahoon

comment:3 Changed 6 years ago by ccahoon

This duplicates behavior in several other tickets, including #9081 which covers this case and many others. I reassigned to myself because this patch has some good additional tests that could be incorporated into the broader solution.

comment:4 Changed 6 years ago by ccahoon

  • Triage Stage changed from Design decision needed to Someday/Maybe

comment:5 Changed 6 years ago by ccahoon

  • Resolution set to duplicate
  • Status changed from new to closed

Actually, I am going to say this is a duplicate of #9081, because they cover the same issue: if and how we should expand render_to_response to allow customization of the HttpResponse.

comment:6 Changed 4 years ago by jacob

  • milestone 1.2 deleted

Milestone 1.2 deleted

Note: See TracTickets for help on using tickets.
Back to Top