Code

Opened 5 years ago

Closed 5 years ago

#10474 closed (duplicate)

Changeset 10029 - syntax error at or near "RETURNING" at character 211

Reported by: aeby Owned by: mtredinnick
Component: Core (Other) Version: master
Severity: Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

changeset:10029 introduces a syntax error (running Django in apache with mod_python):

Traceback (most recent call last):

  File "/usr/lib/python2.4/site-packages/django/core/handlers/base.py", line 89, in get_response
    response = callback(request, *callback_args, **callback_kwargs)

  File "/usr/lib/python2.4/site-packages/django/contrib/auth/decorators.py", line 67, in __call__
    return self.view_func(request, *args, **kwargs)

  File "/srv/atizo/atizo/platform/views/auth.py", line 29, in logout
    django_logout(request)

  File "/usr/lib/python2.4/site-packages/django/contrib/auth/__init__.py", line 75, in logout
    request.session.flush()

  File "/usr/lib/python2.4/site-packages/django/contrib/sessions/backends/base.py", line 240, in flush
    self.create()

  File "/usr/lib/python2.4/site-packages/django/contrib/sessions/backends/db.py", line 36, in create
    self.save(must_create=True)

  File "/usr/lib/python2.4/site-packages/django/contrib/sessions/backends/db.py", line 58, in save
    obj.save(force_insert=must_create)

  File "/usr/lib/python2.4/site-packages/django/db/models/base.py", line 329, in save
    self.save_base(force_insert=force_insert, force_update=force_update)

  File "/usr/lib/python2.4/site-packages/django/db/models/base.py", line 401, in save_base
    result = manager._insert(values, return_id=update_pk)

  File "/usr/lib/python2.4/site-packages/django/db/models/manager.py", line 144, in _insert
    return insert_query(self.model, values, **kwargs)

  File "/usr/lib/python2.4/site-packages/django/db/models/query.py", line 1054, in insert_query
    return query.execute_sql(return_id)

  File "/usr/lib/python2.4/site-packages/django/db/models/sql/subqueries.py", line 315, in execute_sql
    cursor = super(InsertQuery, self).execute_sql(None)

  File "/usr/lib/python2.4/site-packages/django/db/models/sql/query.py", line 2097, in execute_sql
    cursor.execute(sql, params)

ProgrammingError: syntax error at or near "RETURNING" at character 211

Attachments (0)

Change History (2)

comment:1 Changed 5 years ago by ramiro

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset

If you are using PostgreSQL 8.1 then this could be a duplicate of #10467

comment:2 Changed 5 years ago by aeby

  • Resolution set to duplicate
  • Status changed from new to closed

Yes, I'm using PostgreSQL 8.1. It's definitely a duplicate of #10467, so I close this ticket.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.