Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#10246 closed (duplicate)

Bug with Inlines for non-standard primary keys

Reported by: cklein Owned by: nobody
Component: contrib.admin Version: 1.0
Severity: Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:


If the underlying model for an inline defines an alternative primary key
[for example: name = CharField(max_length=32, primary_key=True)]
the Inline is not displayed correctly - the pk field will be rendered twice, including further strange behaviour.

Change History (3)

comment:1 Changed 7 years ago by Tarken

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset

Sounds like a duplicate of #9650

comment:2 Changed 7 years ago by anonymous

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #8903

comment:3 Changed 7 years ago by anonymous

  • milestone post-1.0 deleted

Milestone post-1.0 deleted

Note: See TracTickets for help on using tickets.
Back to Top