Opened 9 years ago

Closed 9 years ago

Last modified 8 years ago

#1013 closed enhancement (wontfix)

[patch] Allow django.views.static to serve index.html instead of a directory listing

Reported by: richie@… Owned by: adrian
Component: Core (Management commands) Version: master
Severity: normal Keywords: index.html static
Cc: Triage Stage: Design decision needed
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

This patch adds an optional parameter called default to django.views.static.serve, which gives the name of a file (eg. index.html) to use in place of a directory listing. This allows django-admin.py runserver to better simulate a real webserver.

Attachments (1)

index-dot-html.diff (1.6 KB) - added by richie@… 9 years ago.
Patch for django/views/static.py

Download all attachments as: .zip

Change History (2)

Changed 9 years ago by richie@…

Patch for django/views/static.py

comment:1 Changed 9 years ago by jacob

  • Resolution set to wontfix
  • Status changed from new to closed

django.static.serve is specifically desgined not to emulate a "real" web server; not serving index.html is by design.

Note: See TracTickets for help on using tickets.
Back to Top