Opened 6 years ago

Closed 6 years ago

#9975 closed (duplicate)

initial data parsing error?

Reported by: antje.gaida@… Owned by: nobody
Component: Database layer (models, ORM) Version: 1.0-beta
Severity: Keywords: syncdb, initial data
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

When I run syncdb with an SQL statement like this in e.g. foo/sql/bar.sql:

INSERT INTO foo_bar (id, sequence)
VALUES (1, 'ATTG--TTC');

it quits with the message:
Failed to install custom SQL for foo.Bar model: unterminated quoted string at or near "'ATTG;" at character *
(
* is the character number... I replaced and shortened my example here, so the original character # will not suit)

Importing the bar.sql from postgres client itself works... that's why I think, the parser is interpreting everthing after '--' as comment... even within strings

Has anybody already a bugfix yet? I couldn't find it here, but maybe I just didn't search for the right words.

Thanks,
Antje

Change History (1)

comment:1 Changed 6 years ago by Alex

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

This is a dupe of #4680 .

Note: See TracTickets for help on using tickets.
Back to Top