Opened 7 years ago

Closed 7 years ago

#9973 closed (duplicate)

url (in template) doesn't accept single quotes

Reported by: liangent Owned by: nobody
Component: Template system Version: 1.0
Severity: Keywords: url
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

If I use {% url viewname 'text' data %} , it doesn't work, and it works when I change it to {% url viewname "text" data %} .

note: some other tags, such as extends , accept single quotes.

Change History (1)

comment:1 Changed 7 years ago by mtredinnick

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

Basically a duplicate of #7295. We're in the processing of fixing it. For now, just use double-quotes everywhere. They always work.

Note: See TracTickets for help on using tickets.
Back to Top