Code

Opened 6 years ago

Closed 5 years ago

#9934 closed (invalid)

Django is generating requests that result in untyped binary data download in FF 3

Reported by: voidfiles Owned by: nobody
Component: HTTP handling Version: 1.0
Severity: Keywords:
Cc: voidfiles@… Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

Hi,

I am having a problem that seems like a ghost. I can find where it's

comming from. It doesn't happen all the time. But what happens is
sometimes when I go to a page. instead of loading the page, the
browsers askes me if I would like to download a file called untyped
binary data.

I am hosting the project on dreamhost. I am use fcgi.

I am starting the requests here in a dispatch.fcgi

#!/home/mysite/opt/bin/python
import sys, os

from flup.server.fcgi import WSGIServer
from django.core.handlers.wsgi import WSGIHandler

# Add a custom Python path.
sys.path.insert(0, "/home/mysite/site_code")

# Switch to the directory of your project. (Optional.)
os.chdir("/home/mysite/site_code")

# Set the DJANGO_SETTINGS_MODULE environment variable.
os.environDJANGO_SETTINGS_MODULE? = "mysite.settings"

WSGIServer(WSGIHandler()).run()

This is what the file looks like that it asks me to download


Attachments (1)

WWUdGtcF.dms.part (2.6 KB) - added by voidfiles 6 years ago.
This is the body of the file it asks me to download.

Download all attachments as: .zip

Change History (4)

Changed 6 years ago by voidfiles

This is the body of the file it asks me to download.

comment:1 Changed 6 years ago by voidfiles

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset

I have been investigating this further, and if you look at the file I attached there is a character at the the front of the HTTP/1.1 I think that might be throwing off the browser.

comment:2 Changed 6 years ago by voidfiles

  • Cc voidfiles@… added
  • Component changed from Uncategorized to HTTP handling

comment:3 Changed 5 years ago by jacob

  • Resolution set to invalid
  • Status changed from new to closed

I can't reproduce this, nor have I ever seen this behavior before on any Django install. I have to assume it's a misconfigured web server on your end, but please feel free to reopen if you can indeed trace this back to a Django bug.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.