Code

Opened 5 years ago

Closed 5 years ago

#9927 closed (duplicate)

views.i18n.javascript_catalog: Locale folder can be in project root, line removed to make this possible.

Reported by: dnordberg Owned by: nobody
Component: Internationalization Version: 1.0
Severity: Keywords: javascript_catalog
Cc: Triage Stage: Unreviewed
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

If the locale folder exists in the project root, this line packages = [p for p in packages if p == 'django.conf' or p in settings.INSTALLED_APPS] causes them to be ignored when creating the javascript i18n translation catalog.

Attachments (2)

js_catalog_locale_can_be_in_project_root (546 bytes) - added by dnordberg@… 5 years ago.
simple fix, removes one line
js_catalog_locale_can_be_in_project_root.diff (896 bytes) - added by anon 5 years ago.
second try

Download all attachments as: .zip

Change History (4)

Changed 5 years ago by dnordberg@…

simple fix, removes one line

comment:1 Changed 5 years ago by dnordberg

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset

To test, without the fix, if you have your djangojs localization files in project/locale not project/app/locale, they wont be picked up in the translation catalog.

Changed 5 years ago by anon

second try

comment:2 Changed 5 years ago by oggy

  • Resolution set to duplicate
  • Status changed from new to closed

This is a duplicate of #5494

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.