Code

Opened 5 years ago

Closed 4 years ago

#9900 closed (duplicate)

Provided generic views for PasswordChange, PasswordReset, etc, does not have a dictionary value for Context

Reported by: nubela Owned by: uptimebox
Component: Contrib apps Version: master
Severity: Keywords:
Cc: Triage Stage: Accepted
Has patch: yes Needs documentation: yes
Needs tests: yes Patch needs improvement: no
Easy pickings: UI/UX:

Description

As stated, the generic views for PasswordChange, PasswordReset, etc, allows for custom templates, however what good are custom templates if the only context values sent to the template is the aligned form? It would be good if there would be an optional dictionary value for Context values.

Attachments (1)

9900-0.diff (7.9 KB) - added by anonymous 5 years ago.

Download all attachments as: .zip

Change History (6)

comment:1 Changed 5 years ago by gwilson

  • Triage Stage changed from Unreviewed to Accepted

Having an extra_context parameter as the regular generic views have seems acceptable. This could also be helped by the work on generic views as classes if the auth views could inherit from that base class.

Changed 5 years ago by anonymous

comment:2 Changed 5 years ago by uptimebox

  • Has patch set
  • Needs tests set
  • Owner changed from nobody to uptimebox
  • Status changed from new to assigned

comment:3 Changed 5 years ago by uptimebox

  • Needs documentation set

comment:4 Changed 5 years ago by anonymous

  • milestone post-1.0 deleted

Milestone post-1.0 deleted

comment:5 Changed 4 years ago by lukeplant

  • Resolution set to duplicate
  • Status changed from assigned to closed

Duplicate of #5298

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.