Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#9849 closed (duplicate)

select_related in admin change_list

Reported by: krylatij Owned by: nobody
Component: contrib.admin Version: master
Severity: Keywords: select_related list_select_related
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

When ForeignKey field appears in list_display django
automaticaly executes select_related() for my model.
So in my case it generates query with about 17 joins. =(
It will be great to manage which fields to query.
additional info here: http://groups.google.com/group/django-developers/browse_thread/thread/491053c89078a3ff

So it's pretty easy to fix without backward incompatibility changes.
As i understand you need to change only django\contrib\admin\views\main.py and django\contrib\admin\validation.py

Change History (2)

comment:1 Changed 6 years ago by ramiro

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

I'm closing this as a duplicate of #9554 and will put a note there pointing back here.

comment:2 Changed 6 years ago by anonymous

  • milestone post-1.0 deleted

Milestone post-1.0 deleted

Note: See TracTickets for help on using tickets.
Back to Top