Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#9744 closed (duplicate)

admin base template does not validate against xhtml 1.0 w3c.org validator

Reported by: terrex Owned by: nobody
Component: contrib.admin Version: 1.0
Severity: Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

There are some problems in admin's base template:

  • Warning No Character Encoding Found! Falling back to UTF-8 (this turns fixed with <?xml version="1.0" encoding="UTF-8" ?> as first line of generated xhtml)
  • conditional-css tags:

# Error Line 5, Column 6: character data is not allowed here.
<![if gte IE 6]><!-- Block all styles from IE5 and lower -->
# Error Line 10, Column 3: "endif" is not a reserved name.
<![endif]>
# Error Line 5, Column 1: XML Parsing Error: StartTag: invalid element name.
<![if gte IE 6]><!-- Block all styles from IE5 and lower -->
# Error Line 10, Column 1: XML Parsing Error: StartTag: invalid element name.
<![endif]>
(I don't know how to solve this)

Change History (2)

comment:1 Changed 6 years ago by dc

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #9492

comment:2 Changed 6 years ago by mtredinnick

The first point here is invalid. The encoding of an XML document without the <? xml... ?> line is assumed (in fact required) to be UTF-8. That is part of the XML specification, including the fact that the XMLDecl line (that first line) is optional. It's not any kind of error to omit that line and including it is verboseness without purpose.

The remainder is the dupe noted by dc.

Note: See TracTickets for help on using tickets.
Back to Top