Code

Opened 5 years ago

Closed 11 months ago

#9684 closed Bug (needsinfo)

Authentication Backend Supresses Some Exceptions

Reported by: dcramer Owned by: nobody
Component: contrib.auth Version: master
Severity: Normal Keywords: dceu13
Cc: eromijn@… Triage Stage: Accepted
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

When using custom backends we noticed that sometimes errors are supressed. One such error was an invalid arguments error for .create() on the default manager.

# throws an exception because it should be a dictionary, instead of a list.
User.objects.create(*args)

The error above is supressed, and simply returns a failure on authenticate(), which can be a headache to debug.

Attachments (0)

Change History (5)

comment:1 Changed 5 years ago by jacob

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Triage Stage changed from Unreviewed to Accepted

comment:2 Changed 3 years ago by lukeplant

  • Severity set to Normal
  • Type set to Bug

comment:3 Changed 2 years ago by aaugustin

  • UI/UX unset

Change UI/UX from NULL to False.

comment:4 Changed 2 years ago by aaugustin

  • Easy pickings unset

Change Easy pickings from NULL to False.

comment:5 Changed 11 months ago by erikr

  • Cc eromijn@… added
  • Keywords dceu13 added
  • Resolution set to needsinfo
  • Status changed from new to closed

Based on the report, I can't really work out what the problem is. Considering the age and lack of activity on this ticket, I am closing it with needsinfo.
Feel free to reopen it if you can provide additional detail, like a more extensive example of the improper behaviour.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.