Opened 6 years ago

Closed 6 years ago

#9681 closed (duplicate)

Unable to load initial data with strings contained two dashes ('--')

Reported by: Alexey Blinov <nilcolor@…> Owned by: nobody
Component: Database layer (models, ORM) Version: 1.0
Severity: Keywords: sql, initial data, model
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

This line in django.core.management.sql make it impossible to add initial data with strings contained two dashes.

statement = re.sub(ur"--.*([\n\Z]|$)", "", statement)

Maybe some kind of shebang string within .sql file to disable this regexp can help?

Change History (1)

comment:1 Changed 6 years ago by kmtracey

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

Dupe of #4680.

Note: See TracTickets for help on using tickets.
Back to Top