Code

Opened 6 years ago

Closed 5 years ago

#9652 closed (fixed)

base.css is not loaded in admin index.html

Reported by: zhaoz Owned by: nobody
Component: contrib.admin Version: master
Severity: Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

Due to change in [source:django/trunk/contrib/admin/media/css/dashboard.css#9463] base.css is no longer being imported in dashboard.css.

However, [source:django/tags/releases/1.0.2/django/contrib/admin/templates/admin/index.html] overrides stylesheet instead of extrastyle.

This is fixed in trunk, but the relased 1.0.2 version has this bug.

Attachments (0)

Change History (5)

comment:1 Changed 6 years ago by kmtracey

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to invalid
  • Status changed from new to closed

I don't understand. dashboard.css on the 1.0.X branch (and in the 1.0.2 release) hasn't changed in 3 years and does import base.css:

http://code.djangoproject.com/browser/django/tags/releases/1.0.2/django/contrib/admin/media/css/dashboard.css

None of the css reorganization that has been done recently has been backported to the 1.0.X branch, as it is not strictly bug-fixing. It rather sounds like you have installed 1.0.2 on top of a trunk checkout or something, and so have a mishmash of both.

comment:2 Changed 5 years ago by crapufish

  • Resolution invalid deleted
  • Status changed from closed to reopened
  • Version changed from 1.0 to SVN

The latest SVN (version 1.1.0 alpha) is missing the @import url('base.css') in the following files: dashboard.css, changelists.css, forms.css, login.css

comment:3 Changed 5 years ago by kmtracey

  • Resolution set to invalid
  • Status changed from reopened to closed

The removal of the import in these files was intentional, see: http://code.djangoproject.com/changeset/9463

Part of that commit message says "Each individual stylesheet is now linked to explicitly from the template where it's used" -- do you have an instance where this is not happening and therefore causes a problem? If so you need to point it out more specifically, because saying the @import is missing is not, in and of itself, a problem. It's just different from the way it used to be done.

comment:4 Changed 5 years ago by hanksims

  • Resolution invalid deleted
  • Status changed from closed to reopened

crapufish: If you're like me, then the problem is caused by your overridden admin templates (after installing django-filebrowser, for instance). You have to update the CSS imports in your custom templates to follow the changes in [9463].

comment:5 Changed 5 years ago by hanksims

  • Resolution set to fixed
  • Status changed from reopened to closed

Sorry, didn't mean to reopen.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.