Code

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#963 closed defect (duplicate)

Save not working with non-integer foreign keys

Reported by: jsprinklex9@… Owned by: adrian
Component: Database layer (models, ORM) Version:
Severity: normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

Hi Django Project. First off, Django rocks! However I ran into a little problem recently. I have a model with non-integer foreign keys (using strings - codes, etc.), and object.save() doesn't work because in fields.get_db_prep_save() the return statement says int(value). This appears to be a recent change, either late last week or early this week I think. Anwyay, that's my take on it, but you may have very good reasons for whatever the change was that is causing this behavior.

Thanks,
-James

Attachments (0)

Change History (2)

comment:1 Changed 8 years ago by jsprinklex9@…

Alright, this is probably a duplicate of ticket #927. Sorry about that.

comment:2 Changed 8 years ago by jacob

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #927.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.