Code

Opened 5 years ago

Closed 5 years ago

#9562 closed (duplicate)

Comment templatetags does not use get_comment_app like the post view does

Reported by: oyvind Owned by: nobody
Component: contrib.comments Version: 1.0
Severity: Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

This should be fixed to make the comments app easier to customize.

Attachments (1)

get_comment_app.diff (1.7 KB) - added by oyvind 5 years ago.
fix to make the comment templatetags use get_comment_app

Download all attachments as: .zip

Change History (3)

Changed 5 years ago by oyvind

fix to make the comment templatetags use get_comment_app

comment:1 Changed 5 years ago by carljm

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset

This will not be necessary if we take the approach I did in the patch for #8630, which is to centralize the get_comment_app logic in one place (init.py), so anyone can call contrib.comments' get_comment_form and friends, and it will always do the right thing.

comment:2 Changed 5 years ago by carljm

  • Resolution set to duplicate
  • Status changed from new to closed

This bug is actually an exact duplicate of #8630, just worded differently. Closing it as such - the patch here could be attached there as an alternative approach.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.