Code

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#9467 closed (duplicate)

Keep search paramenters and filters when editing or saving an entity

Reported by: jacmkno Owned by: jacmkno
Component: contrib.admin Version: 1.0
Severity: Keywords: filters admin add edit keep search listing entity
Cc: Triage Stage: Design decision needed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

If you edit or add an entity using the admin tool from one of the entity listing pages with some filters applied, when you click the save button, you should be taken back to the same listing with the same filters applied. The fields of the Add Form should be pre-filled with the values taken from the filters applied on the listing.

Here is an example situation: You have two models: books and libraries. Let's say that you are looking for a book that you know to be in a library called "Big Library" in the admin application. In the book listing you have a filter by library, so you click "Big Library" link in the filter tool bar. Currently if you edit a book of that list and click the save button, you are taken back to the listing with no filters applied, so the user gets lost.
The expected behavior here is to be taken back to the listing with the same filters applied.
Another expected behavior is that if you are in the same book listing filtered by the "Big Library", and you click the "add book" link at the top. You would expect that the book you are adding will be located at the "Big Library", so the fields inside the Add Form should be pre-filled using the matching information found in the filters applied to the listing.

I fixed these issues for the 0.95 version but I want to have some feedback from the community before proposing an specific change.

I think this issues are very important because the current behavior makes admin usage very confusing for new users.

Attachments (0)

Change History (3)

comment:1 Changed 5 years ago by jacmkno

  • Needs documentation unset
  • Needs tests unset
  • Owner changed from nobody to jacmkno
  • Patch needs improvement unset
  • Triage Stage changed from Unreviewed to Design decision needed

comment:2 Changed 5 years ago by kmtracey

  • Resolution set to duplicate
  • Status changed from new to closed

#2382 asks for the same thing.

comment:3 Changed 5 years ago by anonymous

  • milestone post-1.0 deleted

Milestone post-1.0 deleted

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.