Code

Opened 5 years ago

Closed 5 years ago

#9440 closed (duplicate)

GMarker icon personalization feature in django.contrib.gis.maps.google

Reported by: aromano Owned by: nobody
Component: GIS Version: 1.0
Severity: Keywords:
Cc: Triage Stage: Unreviewed
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

Hi all,
I found it great to have an integrate Google Maps support into Django. However, these modules still do not feature the chance to personalize a GMarker using your own icons, so I have fixed this by adding such a feature into my version. In order to do this, I had to change two files (django/contrib/gis/maps/google/overlays.py and django/contrib/gis/templates/gis/google/js/google-map.js). The patches are attached here to this ticket. Feel free to do whatever you want with them.

Thank you all,
Angelo Romano

Attachments (2)

overlays.py.patch (1.8 KB) - added by aromano 5 years ago.
google-map.js.patch (609 bytes) - added by aromano 5 years ago.

Download all attachments as: .zip

Change History (4)

Changed 5 years ago by aromano

Changed 5 years ago by aromano

comment:1 Changed 5 years ago by jacob

  • Component changed from Uncategorized to GIS

comment:2 Changed 5 years ago by jbronn

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #9204.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.