Opened 7 years ago

Closed 7 years ago

#9395 closed (invalid)

auth docs inconsistency -- built-in forms are now oldforms

Reported by: ivan@… Owned by: nobody
Component: Documentation Version: 1.0
Severity: Keywords: auth built-in forms oldforms
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

Hi, from reading the latest docs on auth here:
http://docs.djangoproject.com/en/dev/topics/auth/#built-in-forms

I ran into a problem in importing:
django.contrib.auth.forms

At the djangobook v1.0, Ch 12:
http://www.djangobook.com/en/1.0/chapter12/

there is a note that explains that "django.contrib.auth.forms.UserCreationForm is, at the time of publication, an oldforms Form." This leads me to believe that all forms under django.contrib.auth.forms are now oldforms.

Could the docs on auth be updated to reflect the current state of builtin auth forms in v1.0? If they are indeed oldforms, then you can just copy the note from the djangobook and list the forms that are oldforms.

thanks!
ivan.

Change History (1)

comment:1 Changed 7 years ago by kmtracey

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to invalid
  • Status changed from new to closed

You don't say what the problem is you ran into when importing django.contrib.auth.forms. If there is some problem here you need to spell it out more clearly. But it sounds more like a user question that would be more appropriate on django-users than in a ticket.

In Django 1.0, there are no more oldforms or newforms, there is just django.forms (which used to be newforms). The Django book was released quite a while before Django 1.0 so its note is outdated. So the conclusion you reached -- that these forms are oldforms -- is incorrect. I don't see any need for the doc to clarify what kind of forms they are, since there is only one forms package in Django 1.0.

Note: See TracTickets for help on using tickets.
Back to Top