Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#9259 closed (fixed)

Failing case in spanish localflavor validator

Reported by: Marc Garcia Owned by: nobody
Component: contrib.localflavor Version: master
Severity: Keywords:
Cc: Triage Stage: Unreviewed
Has patch: yes Needs documentation:
Needs tests: Patch needs improvement:
Easy pickings: UI/UX:

Description

There is a special case that is not behaving as expected when validated by ESIdentityCardNumberField field of the spanish localflavor.

The problem is when validating valid cif number P2907500I, it raises a validation error due to a bug in the code.

Attachments (1)

9259.diff (1.9 KB) - added by Marc Garcia 8 years ago.
Fix and tests

Download all attachments as: .zip

Change History (3)

Changed 8 years ago by Marc Garcia

Attachment: 9259.diff added

Fix and tests

comment:1 Changed 8 years ago by Malcolm Tredinnick

Resolution: fixed
Status: newclosed

(In [9129]) Fixed #9259 -- Fixed a validation error for Spanish identity card numbers.
Patch from Marc Garcia.

comment:2 Changed 8 years ago by Malcolm Tredinnick

(In [9130]) [1.0.X] Fixed #9259 -- Fixed a validation error for Spanish identity card numbers.
Patch from Marc Garcia.

Backport of r9129 from trunk.

Note: See TracTickets for help on using tickets.
Back to Top