Opened 7 years ago

Closed 7 years ago

#9187 closed (duplicate)

forms.DecimalField validation crashes on "INF"

Reported by: epandurski Owned by: nobody
Component: Forms Version: 1.0
Severity: Keywords: decimal, forms
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

The same is true for '-INF', 'INFINITY', 'inf' etc.

Exception is raised in DecimalField's clean() method trying to
obtain abs(), obviously it is assumed that infinite values
have been already filtered.

Change History (1)

comment:1 Changed 7 years ago by kratorius

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #7777.

Note: See TracTickets for help on using tickets.
Back to Top