Code

Opened 6 years ago

Closed 6 years ago

#9131 closed (duplicate)

Lack of documentation for code under django.utils

Reported by: taleinat Owned by: nobody
Component: Documentation Version: 1.0
Severity: Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

As a user of Django, I have no idea whether or not I should use the tools found under django.utils in my code. Some note, somewhere, regarding this would be useful. Maybe I just happened to miss it?

Additionally, finding things under django.utils is difficult unless you search through the code. Just today I was searching for a way to extract just the text from some HTML (certainly a simple task, but not one I want to write my own code for). It took me some time to find django.utils.html.strip_tags. Searching Google for "django strip tags" returns some related code snippets and stuff, but no mention of that function. The same goes for the custom Google search in the Django Documentation website. A reference of some sort (auto-generated?) would be helpful just to have something to search through (and for Google to munch). It would also be helpful to know the state of different utilities, e.g. "deprecated", "stable and well-tested", "likely to change".

Attachments (0)

Change History (1)

comment:1 Changed 6 years ago by russellm

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

This is a duplicate of the intent expressed in the comments for #3469. I've modified that ticket to make it a little more general.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.