Opened 6 years ago

Closed 6 years ago

#9088 closed (invalid)

Problem with svn version 9019

Reported by: Souparnika Owned by: nobody
Component: contrib.admin Version: master
Severity: Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description (last modified by kmtracey)

Hi,

I am trying to use latest svn version (revision 9019) from django. When I try the admin url I am getting an error.

It is copied below.

Template error

In template c:\python25\lib\site-packages\django\contrib\admin\templates\admin\base.html, error at line 25
Caught an exception while rendering: Could not import registration.views. Error was: cannot import name oldforms

15 	<!-- Container -->
16 	<div id="container">
17 	
18 	{% if not is_popup %}
19 	<!-- Header -->
20 	<div id="header">
21 	<div id="branding">
22 	{% block branding %}{% endblock %}
23 	</div>
24 	{% if user.is_authenticated and user.is_staff %}
25 	<div id="user-tools">{% trans 'Welcome,' %} <strong>{% firstof user.first_name user.username %}</strong>. {% block userlinks %}{% url django-admindocs-docroot as docsroot %}{% if docsroot %}<a href="{{ docsroot }}">{% trans 'Documentation' %}</a> / {% endif %}<a href="{{ root_path }}password_change/">{% trans 'Change password' %}</a> / <a href="{{ root_path }}logout/">{% trans 'Log out' %}</a>{% endblock %}</div>
26 	{% endif %}
27 	{% block nav-global %}{% endblock %}
28 	</div>
29 	<!-- END Header -->
30 	{% block breadcrumbs %}<div class="breadcrumbs"><a href="/">{% trans 'Home' %}</a>{% if title %} &rsaquo; {{ title }}{% endif %}</div>{% endblock %}
31 	{% endif %}
32 	
33 	{% if messages %}
34 	<ul class="messagelist">{% for message in messages %}<li>{{ message }}</li>{% endfor %}</ul>
35 	{% endif %} 

Please let me know regarding this.

Change History (2)

comment:1 Changed 6 years ago by kmtracey

  • Description modified (diff)
  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset

comment:2 Changed 6 years ago by kmtracey

  • Resolution set to invalid
  • Status changed from new to closed

This is not a bug in Django, there is no code in Django that attempts to import 'oldforms'. You've got some application code you are running that does, and that is what needs to be fixed.

(The error is showing up where it is because the admin uses {% url django-admindocs-docroot as docsroot %} to conditionally include a Documentation link on each admin page, based on whether the admindocs urls have been configured. This template tag will result in all of your url patterns being evaluated, and problems with any will be reported. You need to find the app you are running that has a registration/views.py file that imports oldforms and upgrade it to use current forms.)

Note: See TracTickets for help on using tickets.
Back to Top