Opened 7 years ago

Closed 7 years ago

#9030 closed (duplicate)

GenericInlineModelAdmin ignores max_num

Reported by: m.trescher@… Owned by: nobody
Component: Contrib apps Version: 1.0
Severity: Keywords: inline, generic
Cc: Triage Stage: Accepted
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

InlineModelAdmin takes the argument "max_num", but GenericInlineModelAdmin ignores this argument.

just add follwoing line in django/trunk/django/contrib/contenttypes/generic.py :

 	            "max_num": self.max_num,

between line 370 and 380.

is it right that a single-line patch doesn't need a patch file?

Change History (3)

comment:1 Changed 7 years ago by brosner

  • Has patch unset
  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Triage Stage changed from Unreviewed to Accepted

In general, yes, *always* attach a patch. They are precise in exactly you want changed and makes it easier for us to apply, test and commit. Next time do so :)

comment:2 Changed 7 years ago by danielr

It also ignores the "exclude" argument. I opened #9122 with a patch for both before seeing this ticket. Should this one be closed, since mine is broader and includes a patch?

comment:3 Changed 7 years ago by mtredinnick

  • Resolution set to duplicate
  • Status changed from new to closed

Closing as a dupe of #9122.

Note: See TracTickets for help on using tickets.
Back to Top