Code

Opened 6 years ago

Closed 6 years ago

#9021 closed (duplicate)

manage.py startapp should create an "default" admin.py file

Reported by: oliverandrich Owned by: nobody
Component: Uncategorized Version: 1.0
Severity: Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

Please look at this ticket as a polite feature request. I have been using the SVN version for some time, but in all projects I started after the newformsadmin merge, I made the same mistake - I added a admin.site.register(SomeClassName) to the models.py, which cause issues with manage.py shell and so on. I personally appreciate the AlreadyRegistered exception.

But as all Django users will use the automatic admin area, it would be a got practice to create a dummy admin.py file with the startapp command. I hope, this is understandable and might lower the learning curve for beginners and people like, whom are upgrading to 1.0.

Attachments (0)

Change History (1)

comment:1 Changed 6 years ago by julian24

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

duplicate of #8173

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.