Code

Opened 6 years ago

Closed 3 years ago

#8928 closed New feature (duplicate)

Make a WSGI compatibility layer for Django middleware

Reported by: simon Owned by: nobody
Component: HTTP handling Version: 1.0
Severity: Normal Keywords:
Cc: andy@…, dane.springmeyer@… Triage Stage: Accepted
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX:

Description

Another Mark Ramm suggestion at DjangoCon.

Attachments (0)

Change History (9)

comment:1 Changed 6 years ago by mramm

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset

The idea here is that there should be easy access to a wsgi environ like dictionary, to make calling wsgi applications from within django trivial.

I would even propose that making a call_wsgi_app function that grabs the environ, creates a start_response callable, calls the wsgi app, and returns the response properly.

This would let users write code like:

def someview(request, *args)
    do_something(args)
    return call_wsgi_app(wsgi_app, request)

This would allow people who use django with SQLAlchemy to user RUM (A django admin like wsgi app) from a veiw, or to use some SOAP wsgi application, or a TurboGears app, or whatever they want in a Django view.

comment:2 Changed 6 years ago by mramm

Ok, previous comment was meant for ticket 8927.

In this case, it would be awesome if the distinction between django middleware and wsgi middleware could mostly go away.

comment:3 Changed 6 years ago by anonymous

  • Cc andy@… added

comment:4 Changed 5 years ago by anonymous

  • milestone post-1.0 deleted

Milestone post-1.0 deleted

comment:5 Changed 5 years ago by jacob

  • Triage Stage changed from Unreviewed to Accepted

comment:6 Changed 5 years ago by anonymous

  • Cc dane.springmeyer@… added

comment:7 Changed 5 years ago by thejaswi_puthraya

  • Component changed from Uncategorized to HTTP handling

comment:8 Changed 3 years ago by lukeplant

  • Severity set to Normal
  • Type set to New feature

comment:9 Changed 3 years ago by lukeplant

  • Easy pickings unset
  • Resolution set to duplicate
  • Status changed from new to closed

This appears to be a dupe of #8927.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.