Opened 7 years ago

Closed 6 years ago

Last modified 4 years ago

#8826 closed (fixed)

URLField links to the current website cause page loading problem when useing Django developing server.

Reported by: ruserious Owned by: kkubasik
Component: Documentation Version: master
Severity: Keywords: URLField kkmegapatch
Cc: Triage Stage: Accepted
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description


Change History (8)

comment:1 Changed 7 years ago by mtredinnick

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset

Please provide some details about the problem you are reporting. It is not at all clear from the title what the issue is.

comment:2 Changed 7 years ago by mtredinnick

  • milestone 1.0 deleted

comment:3 Changed 7 years ago by russellm

I think I can fill in the blanks here - if you have a URLField that is validating, and you are using the development server, and you submit a URL to the URLfield that is served by the development server, you will get a deadlock because the post accepting the URLfield data will lock the server, preventing the URLfield from being validated because the request that validates the URL field cannot be served.

This is one of those edge cases that would be fixed by making the development server multithreaded. However, it is very much an edge case; IMHO, it's worth documenting as an unfortunate edge case, but doesn't really require a fix.

comment:4 Changed 6 years ago by jacob

  • Component changed from Forms to Documentation
  • milestone set to 1.1
  • Triage Stage changed from Unreviewed to Accepted

comment:5 Changed 6 years ago by kkubasik

  • Owner changed from nobody to kkubasik
  • Status changed from new to assigned

As a way to learn the django doc system. If there's no objection I'd like to document this.

comment:6 Changed 6 years ago by kkubasik

  • Keywords kkmegapatch added

Doc in kevins megapatch

comment:7 Changed 6 years ago by jacob

  • Resolution set to fixed
  • Status changed from assigned to closed

(In [10303]) A whole lotta documentation fixes: Fixes #8704, #8826, #8980, #9243, #9343, #9529,

comment:12 Changed 4 years ago by jacob

  • milestone 1.1 deleted

Milestone 1.1 deleted

Note: See TracTickets for help on using tickets.
Back to Top