Code

Opened 6 years ago

Closed 6 years ago

#8675 closed (duplicate)

File storage - Storage objects example does not work

Reported by: whiskybar Owned by: nobody
Component: Documentation Version: master
Severity: Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

The example at the beginning of

http://www.djangoproject.com/documentation/files/#storage-objects

does not work.

>>> from django.core.files.storage import default_storage

>>> path = default_storage.save('/path/to/file', 'new content')

will give you an error:

<type 'exceptions.AttributeError'>: 'str' object has no attribute 'chunks' 

The way to fix is to pass ContentFile('new content') from django.core.files.base. In fact, other examples should be double checked if they expect a string or a ContentFile-like object.

See http://groups.google.com/group/django-users/browse_thread/thread/230a8601a4839bd9 for more information.

Attachments (0)

Change History (1)

comment:1 Changed 6 years ago by julien

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

Dupe of #8641

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.